<!DOCTYPE html>
<html lang="en">
<head>
	<title>Fat Friday: Arcade Fire, The Script, Henry Rollins, Father John Misty, Sarah Millican, Jessie Ware and more | allgigs.co.uk</title>
	<meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
	<meta name="dcterms.rightsHolder" content="AllGigs Limited">
	<meta name="description" content = "Also on sale this week: Metronomy, Foxygen, Frank Iero and the Patience, WWE, Ghostface Killah, Katya Zamolodchikova, John Joseph Brill, Gang of Youth... "/>
	<link rel="stylesheet" type="text/css" media="screen, projection, handheld" href="https://www.allgigs.co.uk/screen.css?1497475283" />
	<link rel="stylesheet" type="text/css" media="screen, projection" href="https://www.allgigs.co.uk/horizontaltabs.css?1442137447" />
    <link rel="stylesheet" type="text/css" media="screen, projection, handheld" href="https://www.allgigs.co.uk/cconsent.css?1443540581" />
	<link rel="stylesheet" type="text/css" media="handheld" href="https://www.allgigs.co.uk/mobile.css?1442137447" />
	<link rel="search" type="application/opensearchdescription+xml" title="Allgigs Search" href="https://www.allgigs.co.uk/sitesearch.xml" />
	<!-- favicon -->
	<link rel="icon" href="https://www.allgigs.co.uk/favicon.ico" type="image/x-icon" />
	<link rel="shortcut icon" href="https://www.allgigs.co.uk/favicon.ico" type="image/x-icon" />
	<script type="text/javascript" src="https://apis.google.com/js/plusone.js">
//	  {lang: 'en-GB'}
	</script>
	<link href="https://www.allgigs.co.uk/feeds/rss/news.rss" rel="alternate" type="application/rss+xml" title="AllGigs News/ Features" />	
<script type="text/javascript" src="https://www.allgigs.co.uk/core.js?1442137446"></script><script type="text/javascript" src="https://www.allgigs.co.uk/jquery/2/jquery-2.1.4.min.js?1234"></script><script type="text/javascript" src="https://www.allgigs.co.uk/bootstrap/js/bootstrap.min.js?1234"></script><script type="text/javascript" src="https://www.allgigs.co.uk/main.js?1463329462"></script><script type="text/javascript" src="https://www.allgigs.co.uk/silktide_cookieconsent.js?1443541365"></script><link rel="stylesheet" type="text/css" media="screen, projection" href="https://www.allgigs.co.uk/status.css?1499812235" /><link rel="stylesheet" type="text/css" media="screen, projection" href="https://www.allgigs.co.uk/accordion-bootstrap.css?1462738353" /><link rel="canonical" href="https://www.allgigs.co.uk/view/article/7072/Fat_Friday_Arcade_Fire_The_Script_Henry_Rollins_Father_John_Misty_Sarah_Millican_Jessie_Ware_And_More.html" /><meta property="og:type" content="article"/>
<meta property="og:image" content="https://www.allgigs.co.uk/images/object/artist/10745/Arcade_Fire1-1-200-200-100-nocrop.jpg"/>
<meta property="og:url" content="https://www.allgigs.co.uk/view/article/7072/Fat_Friday_Arcade_Fire_The_Script_Henry_Rollins_Father_John_Misty_Sarah_Millican_Jessie_Ware_And_More.html"/>
<meta property="og:title" content="Fat Friday: Arcade Fire, The Script, Henry Rollins, Father John Misty, Sarah Millican, Jessie Ware and more"/>
<meta property="og:site_name" content="Allgigs"/>
<meta property="fb:app_id" content="316235678496080"/>
<meta property="og:description" content="Also on sale this week: Metronomy, Foxygen, Frank Iero and the Patience, WWE, Ghostface Killah, Katya Zamolodchikova, John Joseph Brill, Gang of Youth..."/>
<script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-1342811-1']);
_gaq.push(['_trackPageview']);
_gaq.push(['_trackPageLoadTime']);

(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
</head>
<body id="info">
<!-- version 4.0 -->
<div id="fb-root"></div>
<div id="header">
<a href="https://www.allgigs.co.uk/" title="Go to home page"><img src="https://www.allgigs.co.uk/images/allgigslogo.gif" alt="allgigs.co.uk - Gigs, Bands, Venues, News, Competitions and more"/></a>
<div id="headeradwrapper">
<div id="headerad">
<div class="google" id="TextBanner"><script type="text/javascript"><!--

google_ad_client = "ca-pub-5631493207392697";

/* 468x60 - AdSmart header passthrough */

google_ad_slot = "9419498890";

google_ad_width = 468;

google_ad_height = 60;

//-->

</script>

<script type="text/javascript"

src="https://pagead2.googlesyndication.com/pagead/show_ads.js">

</script>
</div>
</div> <!-- /headerad-->
<h2><a href="https://www.allgigs.co.uk/Advertise.php">Advertise here</a></h2>
</div> <!-- /headeradwrapper-->
<div id="offerssplash"  title="Click for our special offers"><a href="/specialoffers/"><span>Special Offers</span></a></div>
</div> <!-- /header-->
<!-- Main page content-->
<div id="page">
<div id="maintext">
<div id="navtabs">
<div class="options"><ul id="maintabs"><li class="first"><a href="https://www.allgigs.co.uk/" title="The Home Page">Home</a></li><li class="selected"><a href="https://www.allgigs.co.uk/whats_on/" title="What's on?">What's On</a></li><li><a href="https://www.allgigs.co.uk/News.php" title="News Overview">Articles</a></li><li><a href="https://www.allgigs.co.uk/specialoffers/" title="Special Offers">Special Offers</a></li><li><a href="https://www.allgigs.co.uk/Contact.php" title="Contact Us">Contact</a></li><li><a href="https://www.allgigs.co.uk/AddMyDetails.php" title="Add Your Events">Add Your Event</a></li><li><a href="https://www.allgigs.co.uk/Help.php" title="Help Me!">Help</a></li><li class="last"><a href="https://www.allgigs.co.uk/aboutus.php" title="About Us">About Us</a></li></ul><div class="clear"></div></div><div class="options secondary"><ul id="secondtabs"><li id="nav_tourshtml"><a href="https://www.allgigs.co.uk/whats_on/guide/tours.html" title="UK/ Ireland Tour Date Round-up">Tours</a></li><li id="nav_festivalshtml"><a href="https://www.allgigs.co.uk/whats_on/guide/festivals.html" title="Festivals Round-up for UK/ Ireland">Festivals</a></li><li id="nav_clubbinghtml"><a href="https://www.allgigs.co.uk/whats_on/guide/clubbing.html" title="UK/ Ireland Clubbing Round-up">Clubbing</a></li><li id="nav_showshtml"><a href="https://www.allgigs.co.uk/whats_on/guide/shows.html" title="Shows/ Theatre Round-up for UK/ Ireland">Theatre</a></li><li id="nav_comedyhtml"><a href="https://www.allgigs.co.uk/whats_on/guide/comedy.html" title="Browse Comedy Events for UK/ Ireland">Comedy</a></li><li id="nav_operahtml"><a href="https://www.allgigs.co.uk/whats_on/guide/opera.html" title="Opera Round-up for UK/ Ireland">Opera</a></li><li id="nav_danceandballethtml"><a href="https://www.allgigs.co.uk/whats_on/guide/dance_and_ballet.html" title="Dance/ Ballet Round-up for UK/ Ireland">Dance</a></li><li id="nav_sportshtml"><a href="https://www.allgigs.co.uk/whats_on/guide/sports.html" title="Browse Sports Events for UK/ Ireland">Sports</a></li><li id="nav_exhibitionshtml" class="last"><a href="https://www.allgigs.co.uk/whats_on/guide/exhibitions.html" title="Browse Exhibitions for UK/ Ireland">Exhibitions</a></li></ul><div class="clear"></div></div></div>
<h1>Fat Friday: Arcade Fire, The Script, Henry Rollins, Father John Misty, Sarah Millican, Jessie Ware and more</h1><div class="fb-like">
		<fb:like href="https://www.allgigs.co.uk/view/article/7072/Fat_Friday_Arcade_Fire_The_Script_Henry_Rollins_Father_John_Misty_Sarah_Millican_Jessie_Ware_And_More.html" send="false" layout="button_count" width="86" show_faces="false" font="arial"></fb:like>
		</div><p class="standfirst">Also on sale this week: <a title="View more info for Metronomy" href="https://www.allgigs.co.uk/view/artist/51186/Metronomy.html">Metronomy</a>, <a title="View more info for Foxygen" href="https://www.allgigs.co.uk/view/artist/75654/Foxygen.html">Foxygen</a>, <a title="View more info for Frank Iero and the Patience" href="https://www.allgigs.co.uk/view/artist/78929/Frank_Iero_And_The_Patience.html">Frank Iero and the Patience</a>, <a title="View more info for WWE" href="https://www.allgigs.co.uk/view/artist/57258/WWE.html">WWE</a>, <a title="View more info for Ghostface Killah" href="https://www.allgigs.co.uk/view/artist/58302/Ghostface_Killah.html">Ghostface Killah</a>, <a title="View more info for Katya Zamolodchikova" href="https://www.allgigs.co.uk/view/artist/82954/Katya-Zamolodchikova.html">Katya Zamolodchikova</a>, <a title="View more info for John Joseph Brill" href="https://www.allgigs.co.uk/view/artist/82510/John-Joseph-Brill.html">John Joseph Brill</a>, <a title="View more info for Gang of Youths" href="https://www.allgigs.co.uk/view/artist/82103/Gang-Of-Youths.html">Gang of Youths</a>, <a title="View more info for DJ Craig Charles" href="https://www.allgigs.co.uk/view/artist/58916/DJ_Craig_Charles.html">DJ Craig Charles</a>, <a title="View more info for Uli Jon Roth" href="https://www.allgigs.co.uk/view/artist/4851/Uli_Jon_Roth.html">Uli Jon Roth</a>, <a title="View more info for London Restaurant Festival" href="https://www.allgigs.co.uk/view/artist/64630/London_Restaurant_Festival.html">London Restaurant Festival</a> and more</p><div class="news ticketroundup"><table class="artisttable"><thead></thead><tbody><tr class="onsale"><td><div class="onsale single">On sale Friday</div><div ><a href="https://www.allgigs.co.uk/view/artist/10745/Arcade_Fire.html"><img src="https://www.allgigs.co.uk/images/object/artist/10745/Arcade_Fire1-1-160-160-95-crop.jpg" alt="Arcade Fire"/></a><div title="Arcade Fire" class="caption">&nbsp;</div></div></td><td><div class="onsale single">On sale Friday</div><div ><a href="https://www.allgigs.co.uk/view/artist/53832/The_Script.html"><img src="https://www.allgigs.co.uk/images/object/artist/53832/The_Script1-1-160-160-95-crop.jpg" alt="The Script"/></a><div title="The Script" class="caption">&nbsp;</div></div></td><td><div class="onsale single">On sale Friday</div><div ><a href="https://www.allgigs.co.uk/view/artist/573/Henry_Rollins.html"><img src="https://www.allgigs.co.uk/images/object/artist/573/Henry_Rollins-1-160-160-95-crop.jpg" alt="Henry Rollins"/></a><div title="Henry Rollins" class="caption">&nbsp;</div></div></td><td><div class="onsale single">On sale Friday</div><div ><a href="https://www.allgigs.co.uk/view/artist/74216/Father_John_Misty.html"><img src="https://www.allgigs.co.uk/images/object/artist/74216/Father_John_Misty-1-160-160-95-crop.jpg" alt="Father John Misty - Image: fatherjohnmisty.tumblr.com/"/></a><div title="Father John Misty" class="caption">&nbsp;</div><div class="credit">Image: <a href="http://fatherjohnmisty.tumblr.com" rel="nofollow" target="_blank">link</a>/</div></div></td></tr>
<tr><td><a href="https://www.allgigs.co.uk/view/artist/10745/Arcade_Fire.html">Arcade Fire</a> April 2018 in London, Dublin, Manchester, Birmingham and Glasgow.</td><td><a href="https://www.allgigs.co.uk/view/artist/53832/The_Script.html">The Script</a> from 21st August to 1st September in London, Dublin, Londonderry, Birmingham, Swindon and more around £45.50.</td><td><a href="https://www.allgigs.co.uk/view/artist/573/Henry_Rollins.html">Henry Rollins</a> Henry Rollins Travel Slideshow - February 2018 in Norwich, Manchester and Sheffield from £20. Tickets already available for London.</td><td><a href="https://www.allgigs.co.uk/view/artist/74216/Father_John_Misty.html">Father John Misty</a> on 9th November in Brighton from £22.50. Tickets already available for London, Edinburgh, Glasgow, Cardiff and more.</td></tr>
<tr class="onsale"><td><div class="onsale single">On sale now</div><div ><a href="https://www.allgigs.co.uk/view/artist/58779/Sarah_Millican.html"><img src="https://www.allgigs.co.uk/images/object/artist/58779/Sarah_Millican-1-160-160-95-crop.jpg" alt="Sarah Millican"/></a><div title="Sarah Millican" class="caption">&nbsp;</div></div></td><td><div class="onsale single">On sale tomorrow</div><div ><a href="https://www.allgigs.co.uk/view/artist/72980/Jessie_Ware.html"><img src="https://www.allgigs.co.uk/images/object/artist/72980/Jessie_Ware1-1-160-160-95-crop.jpg" alt="Jessie Ware - Image: www.facebook.com/jessiewaremusic"/></a><div title="Jessie Ware" class="caption">&nbsp;</div><div class="credit">Image: <a href="http://www.facebook.com/jessiewaremusic" rel="nofollow" target="_blank">link</a></div></div></td><td><div class="onsale single">On sale Friday</div><div ><a href="https://www.allgigs.co.uk/view/artist/51186/Metronomy.html"><img src="https://www.allgigs.co.uk/images/object/artist/51186/Metronomy-1-160-160-95-crop.jpg" alt="Metronomy"/></a><div title="Metronomy" class="caption">&nbsp;</div></div></td><td><div class="onsale single">On sale Friday</div><div ><a href="https://www.allgigs.co.uk/view/artist/75654/Foxygen.html"><img src="https://www.allgigs.co.uk/images/object/artist/75654/Foxygen-1-160-160-95-crop.jpg" alt="Foxygen"/></a><div title="Foxygen" class="caption">&nbsp;</div></div></td></tr>
<tr><td><a href="https://www.allgigs.co.uk/view/artist/58779/Sarah_Millican.html">Sarah Millican</a> Control Enthusiast tour-dates on 7th July 2018 and 2nd November 2018 in Newcastle and Portsmouth from £27.50 to £28. More tickets on sale Wednesday. Tickets already available for London, Lancaster, Cumbria, Weston-super-Mare etc. with more to be announced.</td><td><a href="https://www.allgigs.co.uk/view/artist/72980/Jessie_Ware.html">Jessie Ware</a> September in London from £25. Two exclusive (so far) shows in Islington.</td><td><a href="https://www.allgigs.co.uk/view/artist/51186/Metronomy.html">Metronomy</a> on 21st October in Birmingham from £19.50.</td><td><a href="https://www.allgigs.co.uk/view/artist/75654/Foxygen.html">Foxygen</a> on 7th October in London from £17.50. Exclusive show.</td></tr>
<tr class="onsale"><td><div class="onsale single">On sale Friday</div><div ><a href="https://www.allgigs.co.uk/view/artist/78929/Frank_Iero_And_The_Patience.html"><img src="https://www.allgigs.co.uk/images/object/artist/78929/Frank_Iero_And_The_Patience-1-160-160-95-crop.jpg" alt="Frnkiero"/></a><div title="Frnkiero" class="caption">&nbsp;</div></div></td><td><div class="onsale single">On sale Thursday</div><div ><a href="https://www.allgigs.co.uk/view/artist/57258/WWE.html"><img src="https://www.allgigs.co.uk/images/object/artist/57258/WWE-1-160-160-95-crop.jpg" alt="WWE - Image: www.wwe.com"/></a><div title="WWE" class="caption">&nbsp;</div><div class="credit">Image: <a href="http://www.wwe.com" rel="nofollow" target="_blank">link</a></div></div></td><td><div class="onsale single">On sale tomorrow</div><div ><a href="https://www.allgigs.co.uk/view/artist/58302/Ghostface_Killah.html"><img src="https://www.allgigs.co.uk/images/object/artist/58302/Ghostface_Killah1-1-160-160-95-crop.jpg" alt="Ghostface Killah"/></a><div title="Ghostface Killah" class="caption">&nbsp;</div></div></td><td><div class="onsale single">On sale Friday</div><div ><a href="https://www.allgigs.co.uk/view/artist/82954/Katya-Zamolodchikova.html"><img src="https://www.allgigs.co.uk/images/object/artist/82954/Katya_Zamolodchikova1-1-160-160-95-crop.jpg" alt="Katya Zamolodchikova"/></a><div title="Katya Zamolodchikova" class="caption">&nbsp;</div></div></td></tr>
<tr><td><a href="https://www.allgigs.co.uk/view/artist/78929/Frank_Iero_And_The_Patience.html">Frank Iero and the Patience</a> from 20th September to 18th October in Newcastle, Liverpool, Brighton, Bristol, Cardiff and many more from £17 to £17.50.</td><td><a href="https://www.allgigs.co.uk/view/artist/57258/WWE.html">WWE</a> on 2nd November in Dublin. Tickets already available for London, Glasgow, Brighton, Aberdeen and more.</td><td><a href="https://www.allgigs.co.uk/view/artist/58302/Ghostface_Killah.html">Ghostface Killah</a> on 22nd September in Birmingham from £15. Tickets already available for Northampton.</td><td><a href="https://www.allgigs.co.uk/view/artist/82954/Katya-Zamolodchikova.html">Katya Zamolodchikova</a> An Evening with Katya Zamolodchikova February 2018 in London, Brighton, Birmingham and Glasgow.</td></tr>
<tr class="onsale"><td><div class="onsale single">On sale now</div><div ><a href="https://www.allgigs.co.uk/view/artist/82510/John-Joseph-Brill.html"><img src="https://www.allgigs.co.uk/images/object/artist/82510/John_Joseph_Brill-1-160-160-95-crop.jpg" alt="John Joseph Brill - Image: twitter.com/JohnJosephBrill"/></a><div title="John Joseph Brill" class="caption">&nbsp;</div><div class="credit">Image: twitter.com/JohnJosephBrill</div></div></td><td><div class="onsale single">On sale Thursday</div><div ><a href="https://www.allgigs.co.uk/view/artist/82103/Gang-Of-Youths.html"><img src="https://www.allgigs.co.uk/images/object/artist/82103/Gang_Of_Youths-1-160-160-95-crop.jpg" alt="Gang of Youths"/></a><div title="Gang of Youths" class="caption">&nbsp;</div></div></td><td><div class="onsale single">On sale now</div><div ><a href="https://www.allgigs.co.uk/view/artist/58916/DJ_Craig_Charles.html"><img src="https://www.allgigs.co.uk/images/object/artist/58916/DJ_Craig_Charles-1-160-160-95-crop.jpg" alt="DJ Craig Charles"/></a><div title="DJ Craig Charles" class="caption">&nbsp;</div></div></td><td><div class="onsale single">On sale now</div><div ><a href="https://www.allgigs.co.uk/view/artist/4851/Uli_Jon_Roth.html"><img src="https://www.allgigs.co.uk/images/object/artist/4851/Uli_Jon_Roth1-1-160-160-95-crop.gif" alt="Uli Jon Roth"/></a><div title="Uli Jon Roth" class="caption">&nbsp;</div></div></td></tr>
<tr><td><a href="https://www.allgigs.co.uk/view/artist/82510/John-Joseph-Brill.html">John Joseph Brill</a> November in Brighton, Bristol, Leeds, Birmingham, Oxford and many more around £8. Tickets already available for London, Edinburgh and Inverness.</td><td><a href="https://www.allgigs.co.uk/view/artist/82103/Gang-Of-Youths.html">Gang of Youths</a> October in London, Bristol, Leeds and Northern Quarter from £9 to £20.</td><td><a href="https://www.allgigs.co.uk/view/artist/58916/DJ_Craig_Charles.html">DJ Craig Charles</a> The Craig Charles Funk & Soul Club on 6th October in Exeter from £17.50. Tickets already available for London, Blackpool, Monmouthshire, Manchester and more.</td><td><a href="https://www.allgigs.co.uk/view/artist/4851/Uli_Jon_Roth.html">Uli Jon Roth</a> December in London, Sheffield and Newcastle from £18.50 to £22. Tickets already available for York.</td></tr>
<tr class="onsale"><td><div class="onsale single">On sale now</div><div ><a href="https://www.allgigs.co.uk/view/artist/64630/London_Restaurant_Festival.html"><img src="https://www.allgigs.co.uk/images/object/artist/64630/London_Restaurant_Festival-1-160-160-95-crop.gif" alt="London Restaurant Festival"/></a><div title="London Restaurant Festival" class="caption">&nbsp;</div></div></td><td><div class="onsale single">On sale tomorrow</div><div ><a href="https://www.allgigs.co.uk/view/artist/62248/Wolf_Parade.html"><img src="https://www.allgigs.co.uk/images/object/artist/62248/Wolf_Parade1-1-160-160-95-crop.jpg" alt="Wolf Parade - Image: twitter.com/WolfParade"/></a><div title="Wolf Parade" class="caption">&nbsp;</div><div class="credit">Image: twitter.com/WolfParade</div></div></td><td><div class="onsale single">On sale tomorrow</div><div ><a href="https://www.allgigs.co.uk/view/artist/79963/The-Spitfires.html"><img src="https://www.allgigs.co.uk/images/object/artist/79963/The_Spitfires-1-160-160-95-crop.jpg" alt="The Spitfires"/></a><div title="The Spitfires" class="caption">&nbsp;</div></div></td><td><div class="onsale single">On sale tomorrow</div><div ><a href="https://www.allgigs.co.uk/view/artist/79444/The-One-Hundred.html"><img src="https://www.allgigs.co.uk/images/object/artist/79444/The_One_Hundred-1-160-160-95-crop.jpg" alt="The One Hundred - Image: www.facebook.com/theonehundredband"/></a><div title="The One Hundred" class="caption">&nbsp;</div><div class="credit">Image: <a href="http://www.facebook.com/theonehundredband" rel="nofollow" target="_blank">link</a></div></div></td></tr>
<tr><td><a href="https://www.allgigs.co.uk/view/artist/64630/London_Restaurant_Festival.html">London Restaurant Festival</a> October in London from £35. Includes acclaimed chefs, events and films.</td><td><a href="https://www.allgigs.co.uk/view/artist/62248/Wolf_Parade.html">Wolf Parade</a> November in London, Temple Bar and Manchester around £17.50.</td><td><a href="https://www.allgigs.co.uk/view/artist/79963/The-Spitfires.html">The Spitfires</a> from 27th October to 17th November in Southend, Birmingham, Glasgow, Dunfermline and Liverpool from £12.50. More tickets on sale Friday. Tickets already available for Manchester, Wigan and Leeds.</td><td><a href="https://www.allgigs.co.uk/view/artist/79444/The-One-Hundred.html">The One Hundred</a> on 13th October in London from £11. Exclusive show.</td></tr>
</tbody></table><h3>New tickets on sale this week</h3><div class="picturebar"><div class = "thumbnail"><a href="https://www.allgigs.co.uk/view/artist/82955/River-Matthews.html" title="Buy tickets for River Matthews  from Wednesday 26th Jul 2017"><img src="https://www.allgigs.co.uk/images/object/artist/82955/River_Matthews1-1-95-95-85-crop.jpg" alt="River Matthews"/></a><div title="River Matthews" class="caption"><a href="https://www.allgigs.co.uk/view/artist/82955/River-Matthews.html" title="Buy tickets for River Matthews  from Wednesday 26th Jul 2017">River Matthews</a></div></div><div class = "thumbnail"><a href="https://www.allgigs.co.uk/view/artist/82205/Gurr.html" title="Buy tickets for Gurr  from Wednesday 26th Jul 2017"><img src="https://www.allgigs.co.uk/images/object/artist/82205/Gurr-1-95-95-85-crop.jpg" alt="Gurr"/></a><div title="Gurr" class="caption"><a href="https://www.allgigs.co.uk/view/artist/82205/Gurr.html" title="Buy tickets for Gurr  from Wednesday 26th Jul 2017">Gurr</a></div></div><div class = "thumbnail"><a href="https://www.allgigs.co.uk/view/artist/82956/Saint-PHNX.html" title="Buy tickets for Saint PHNX  from Wednesday 26th Jul 2017"><img src="https://www.allgigs.co.uk/images/object/artist/82956/Saint_PHNX1-1-95-95-85-crop.jpg" alt="Saint PHNX"/></a><div title="Saint PHNX" class="caption"><a href="https://www.allgigs.co.uk/view/artist/82956/Saint-PHNX.html" title="Buy tickets for Saint PHNX  from Wednesday 26th Jul 2017">Saint PHNX</a></div></div><div class = "thumbnail"><a href="https://www.allgigs.co.uk/view/artist/79260/Ben-Haenow.html" title="Buy tickets for Ben Haenow  from Monday 31st Jul 2017"><img src="https://www.allgigs.co.uk/images/object/artist/79260/Ben_Haenow-1-95-95-85-crop.jpg" alt="Ben Haenow"/></a><div title="Ben Haenow" class="caption"><a href="https://www.allgigs.co.uk/view/artist/79260/Ben-Haenow.html" title="Buy tickets for Ben Haenow  from Monday 31st Jul 2017">Ben Haenow</a></div></div><div class = "thumbnail"><a href="https://www.allgigs.co.uk/view/artist/74645/Jo_Harman.html" title="Buy tickets for Jo Harman  from Wednesday 26th Jul 2017"><img src="https://www.allgigs.co.uk/images/object/artist/74645/Jo_Harman-1-95-95-85-crop.jpg" alt="Jo Harman"/></a><div title="Jo Harman" class="caption"><a href="https://www.allgigs.co.uk/view/artist/74645/Jo_Harman.html" title="Buy tickets for Jo Harman  from Wednesday 26th Jul 2017">Jo Harman</a></div></div><div class = "thumbnail"><a href="https://www.allgigs.co.uk/view/artist/81027/Against-The-Current.html" title="Buy tickets for Against the Current  from Wednesday 26th Jul 2017"><img src="https://www.allgigs.co.uk/images/object/artist/81027/Against_The_Current-1-95-95-85-crop.jpg" alt="Against the Current"/></a><div title="Against the Current" class="caption"><a href="https://www.allgigs.co.uk/view/artist/81027/Against-The-Current.html" title="Buy tickets for Against the Current  from Wednesday 26th Jul 2017">Against the Current</a></div></div><div class = "thumbnail"><a href="https://www.allgigs.co.uk/view/artist/80358/Green-Haze.html" title="Buy tickets for Green Haze  from Wednesday 26th Jul 2017"><img src="https://www.allgigs.co.uk/images/object/artist/80358/Green_Haze-1-95-95-85-crop.jpg" alt="Green Haze"/></a><div title="Green Haze" class="caption"><a href="https://www.allgigs.co.uk/view/artist/80358/Green-Haze.html" title="Buy tickets for Green Haze  from Wednesday 26th Jul 2017">Green Haze</a></div></div><div class = "thumbnail"><a href="https://www.allgigs.co.uk/view/artist/51333/Antarctic_Monkeys.html" title="Buy tickets for Antarctic Monkeys  from Friday 28th Jul 2017"><img src="https://www.allgigs.co.uk/images/object/artist/51333/Antarctic_Monkeys-1-95-95-85-crop.jpg" alt="Antarctic Monkeys - Image: www.antarcticmonkeys.com"/></a><div title="Antarctic Monkeys" class="caption"><a href="https://www.allgigs.co.uk/view/artist/51333/Antarctic_Monkeys.html" title="Buy tickets for Antarctic Monkeys  from Friday 28th Jul 2017">Antarctic Monkeys</a></div><div class="credit">Image: <a href="http://www.antarcticmonkeys.com" rel="nofollow" target="_blank">www.antarcticmonkeys.com</a></div></div><div class="clear"></div></div><div id="socialblock">For up-to-the minute event announcements, last-minute ticket availability and exclusive competitions, follow us on our <a href="http://www.facebook.com/allgigs" rel="nofollow" target="_blank">Facebook Page</a>, our <a href="http://www.twitter.com/allgigs" rel="nofollow" target="_blank">Twitter Page</a> and/ or our <a href="http://www.pinterest.com/allgigs" rel="nofollow" target="_blank">Pinterest Page</a> and don't forget to sign-up to our <a href="/newsletter.php">Newsletter</a>.</div></div></div>
<!--/MAINTEXT-->
<!--SIDEBAR-->
<div id="sidebar">
	<form id="sitesearchform" method="post" action="/sitesearch.php" onsubmit="return canSiteSearch(this);"><h2>Search allgigs</h2><input  title="Enter band/ artist/ event/ venue name and press 'Search'"        type="text"        placeholder="artist/ band/ venue/ region"        id="searchbox"        name="search"/><button type="submit" class="go" title="Enter your search terms on the left and click 'Search' to search">Search</button></form>
<h2>Subscribe to our Newsletter</h2><ul class="feeds"><li class="newsletter"><a id="newsletter_link" href="/newsletter.php" title="Sign-up to our email newsletter">Sign Me Up!</a></li></ul><div id="newslettersubscribe"><form action="https://allgigs.us1.list-manage1.com/subscribe/post?u=2b40b7846556a258b89775afe&amp;id=f7dbf15fb2" method="post" target="_blank" class="mailsubscribe">
<p>Stay in touch! Our newsletters  feature the latest tour, festival, show, comedy, arts news and more - as well as <strong>exclusive competitions!</strong></p>
<label for="EMAIL">Email Address </label>
<input type="text" value="" name="EMAIL" id="EMAIL"/>
<label for="FNAME">First Name </label>
<input type="text" value="" name="FNAME" id="FNAME"/>
<label for="LNAME">Last Name </label>
<input type="text" value="" name="LNAME" id="LNAME"/>
    <label>Gender </label>
    <ul><li><input type="radio" value="Male" name="MMERGE3" id="MMERGE3-0"/><label for="MMERGE3-0">Male</label></li>
	<li><input type="radio" value="Female" name="MMERGE3" id="MMERGE3-1"/><label for="MMERGE3-1">Female</label></li>
	</ul>
    <label>Interested in </label>
    <ul><li><input type="checkbox" value="1" name="group[1]" id="group-2-0" title="The latest gig, tour and festival news and ticket on-sales"/><label for="group-2-0" title="The latest gig, tour and festival news and ticket on-sales">Gigs, Tours and Festivals newsletter</label></li>
<li><input type="checkbox" value="2" name="group[2]" id="group-2-1" title="The latest theatre, show, opera, ballet and comedy news and events"/><label for="group-2-1" title="The latest theatre, show, opera, ballet and comedy news and events">Theatre, Arts and Comedy newsletter</label></li>
<li><input type="checkbox" value="4" name="group[4]" id="group-2-2" title="Our ad-hoc event alert informs you of last minute ticket on-sales - never more than one per day"/><label for="group-2-2" title="Our ad-hoc event alert informs you of last minute ticket on-sales - never more than one per day">Event Alerts</label></li>
</ul>
<div class="privacy">
<h3>Privacy Policy</h3>
<p>We take privacy seriously at allgigs.co.uk, so rest assured that the
information you provide is stored securely and will not be sold on or
otherwise passed on to any third party.</p>
</div>
<input type="submit" value="Subscribe" class="btn"/>
</form>
</div>
<h2 class="feeds">Follow Us</h2>
<ul class="feeds"><li class="facebook"><a rel="nofollow" href="https://www.facebook.com/allgigs" target="_blank" title="Follow allgigs on Facebook">Facebook</a></li><li class="twitter"><a rel="nofollow" href="https://twitter.com/allgigs" target="_blank" title="Follow allgigs on Twitter">Twitter</a></li><li class="pinterest"><a rel="nofollow" href="https://pinterest.com/allgigs" target="_blank" title="Follow allGigs on Pinterest">Pinterest</a></li><li class="RSS"><a href="https://www.allgigs.co.uk/feeds/rss/news.rss" target="_blank" title="allgigs news feed">News</a></li><div class="clear"></div></ul>
<div class="updates"><div class="inner"><h2>Updates</h2><ul><li>
		<span class="pinned" title="Pinned"><span>pinned</span></span>
		<span class="time" title="posted Thursday">Thursday</span>
		<a href="https://www.allgigs.co.uk/view/artist/10745/Arcade_Fire.html">
		<img title="Arcade Fire" src="https://www.allgigs.co.uk/images/object/artist/10745/Arcade_Fire1-1-50-50-100-crop.jpg" alt="Arcade Fire"/>
		<span class="title">Arcade Fire</span></a>
		<span class="status">have announced a spring UK/ Ireland arena tour. <a href="https://www.allgigs.co.uk/view/artist/10745/Arcade_Fire.html">Tickets on sale Friday</a></span>
		<div class="clear"></div></li></ul></div></div>
<h2><a href="https://www.allgigs.co.uk/Advertise.php">Advertise Here</a></h2><div class="adverts"><div class="advert"><script type="text/javascript"><!--
google_ad_client = "ca-pub-5631493207392697";
/* 300 x 250 - second slot */
google_ad_slot = "3872732406";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div></div><h2>Correction!</h2><ul><li><a title="Correct a mistake/ provide more info" href="mailto:correction@allgigs.co.uk?subject=Correction%20for%20https%3A%2F%2Fwww.allgigs.co.uk%2Fview%2Farticle%2F7072%2FFat_Friday_Arcade_Fire_The_Script_Henry_Rollins_Father_John_Misty_Sarah_Millican_Jessie_Ware_And_More.html&amp;body=Correction%20for%20https%3A%2F%2Fwww.allgigs.co.uk%2Fview%2Farticle%2F7072%2FFat_Friday_Arcade_Fire_The_Script_Henry_Rollins_Father_John_Misty_Sarah_Millican_Jessie_Ware_And_More.html%0D%0A%0D%0APlease%20enter%20the%20details%20here">correction@allgigs.co.uk</a></li></ul><h2>News</h2><dl><dt>Article Date:</dt><dd><strong>Tuesday, 25th Jul 2017</strong></dd><dt>Like This? Share It!:</dt><dd><ul id="socialshare">
                                <li><a href="https://www.facebook.com/sharer.php?u=https://www.allgigs.co.uk/view/article/7072/Fat_Friday_Arcade_Fire_The_Script_Henry_Rollins_Father_John_Misty_Sarah_Millican_Jessie_Ware_And_More.html&amp;t=Fat+Friday%3A+Arcade+Fire%2C+The+Script%2C+Henry+Rollins%2C+Father+John+Misty%2C+Sarah+Millican%2C+Jessie+Ware+and+more" target="_blank" rel="nofollow"><img alt="Facebook logo" src="/images/icons/facebook-share.png" title="Share on Facebook!"/></a></li>
                                <li><a href="https://twitter.com/home/?status=Fat%20Friday%3A%20Arcade%20Fire%2C%20The%20Script%2C%20Henry%20Rollins%2C%20Father%20John%20Misty%2C%20Sarah%20Millican%2C%20Jessie%20Ware%20and%20more%20http://bit.ly/2vWrGud" target="_blank" rel="nofollow"><img alt="Twitter logo" src="/images/icons/tweet.png" title="Tweet about it!"/></a></li>
<li><g:plusone size="medium" count="false"></g:plusone></li>
                                <li><a href="mailto:YourFriend?subject=Fat%20Friday%3A%20Arcade%20Fire%2C%20The%20Script%2C%20Henry%20Rollins%2C%20Father%20John%20Misty%2C%20Sarah%20Millican%2C%20Jessie%20Ware%20and%20more%20on%20www.allgigs.co.uk&amp;body=Hi%2C%0D%0A%0D%0AThought%20you%20might%20be%20interested%20in%20this%3A%20Fat%20Friday%3A%20Arcade%20Fire%2C%20The%20Script%2C%20Henry%20Rollins%2C%20Father%20John%20Misty%2C%20Sarah%20Millican%2C%20Jessie%20Ware%20and%20more%0D%0A%0D%0AInfo%3A%20https%3A%2F%2Fwww.allgigs.co.uk%2Fview%2Farticle%2F7072%2FFat_Friday_Arcade_Fire_The_Script_Henry_Rollins_Father_John_Misty_Sarah_Millican_Jessie_Ware_And_More.html" target="_blank" rel="nofollow"><img alt="email icon" src="/images/icons/emailicon.png" title="Email a friend about this"/></a></li><div class="clear"></div></ul></dd></dl><h2>Festivals</h2><ul><li><a href="https://www.allgigs.co.uk/whats_on/guide/festivals.html" title="Festivals in the UK">UK: Festivals</a></li></ul><h2>Shows/ Theatre</h2><ul><li><a href="https://www.allgigs.co.uk/whats_on/guide/shows.html" title="Shows/ Theatre in the UK">UK: Shows/ Theatre</a></li></ul><h2>Comedy</h2><ul><li><a href="https://www.allgigs.co.uk/whats_on/guide/comedy.html" title="Comedy in the UK">UK: Comedy</a></li></ul><h2>Exhibitions</h2><ul><li><a href="https://www.allgigs.co.uk/whats_on/guide/exhibitions.html" title="Exhibitions in the UK">UK: Exhibitions</a></li></ul><h2>Tours</h2><ul><li><a href="https://www.allgigs.co.uk/whats_on/guide/tours.html" title="Tours in the UK">UK: Tours</a></li></ul><h2>Sports</h2><ul><li><a href="https://www.allgigs.co.uk/whats_on/guide/sports.html" title="Sports in the UK">UK: Sports</a></li></ul><h2>Related News</h2><ul class="newslist"><li><span title="When was the article posted?" class="date">NEW:</span><a href="https://www.allgigs.co.uk/view/article/7071/The_Week_Ahead_With_PJ_Harvey_The_Libertines_Manic_Street_Preachers_Kaiser_Chiefs_Rebellion_Festival_Jamaica_House_And_More.html" title="The Week Ahead with PJ Harvey, The Libertines, Manic Street Preachers, Kaiser Chiefs, Rebellion Festival, Jamaica House and more">The Week Ahead with <span class="ARTISTS">PJ Harvey</span>, <span class="ARTISTS">The Libertines</span>, <span class="ARTISTS">Manic Street Preachers</span>, <span class="ARTISTS">Kaiser Chiefs</span>, <span class="ARTISTS">Rebellion Festival</span>, <span class="ARTISTS">Jamaica House</span> and more</a></li><li><span title="When was the article posted?" class="date">This Month:</span><a href="https://www.allgigs.co.uk/view/article/5346/Hip_Hop_Wont_Stop_The_Definitive_UK_Ireland_Hip_Hop_Guide.html" title="Hip Hop won't stop: The definitive UK/ Ireland Hip Hop Guide">Hip Hop won't stop: The definitive UK/ Ireland Hip Hop Guide</a></li><li><a href="https://www.allgigs.co.uk/view/article/7070/Fat_Friday_With_Lana_Del_Rey_Goldfrapp_The_Killers_The_War_On_Drugs_The_Warehouse_Project_BNQT_Margaret_Cho_Simon_Reeve_And_More.html" title="Fat Friday with Lana Del Rey, Goldfrapp, The Killers, The War On Drugs, The Warehouse Project, BNQT, Margaret Cho, Simon Reeve and more ">Fat Friday with <span class="ARTISTS">Lana Del Rey</span>, <span class="ARTISTS">Goldfrapp</span>, <span class="ARTISTS">The Killers</span>, <span class="ARTISTS">The War On Drugs</span>, <span class="ARTISTS">The Warehouse Project</span>, <span class="ARTISTS">BNQT</span>, <span class="ARTISTS">Margaret Cho</span>, <span class="ARTISTS">Simon Reeve</span> and more </a></li><li><a href="https://www.allgigs.co.uk/view/article/2651/2017_Festival_Guide_A_Roundup_Of_UK_Ireland_And_International_Festivals.html" title="2017 Festival Guide - a round-up of UK, Ireland and International festivals">2017 Festival Guide - a round-up of UK, Ireland and International festivals</a></li></ul><h2><a href="https://www.allgigs.co.uk/Advertise.php">Advertise Here</a></h2><div class="adverts"><div class="advert"><!-- TopMPU --><script type="text/javascript"><!--
google_ad_client = "ca-pub-5631493207392697";
/* 300x250, created 31/01/10 */
google_ad_slot = "9749543206";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="https://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div></div></div>
<!--/SIDEBAR-->
<script type="text/javascript">
dateSearchEnable('main_searchtype','main_fromselection');
</script>
<!--FOOTER-->
<div class="clear"></div><div>
<ul id="sitemapfooter"><li>What's On:<ul><li><a href="https://www.allgigs.co.uk/click/TodaysGigs/">Today's Gigs</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/tours.html">Tours</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/festivals.html">Festivals</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/clubbing.html">Clubbing</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/shows.html">Theatre</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/comedy.html">Comedy</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/opera.html">Opera</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/dance_and_ballet.html">Dance</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/sports.html">Sports</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/exhibitions.html">Exhibitions</a></li></ul></li><li>By Region:<ul><li><a href="https://www.allgigs.co.uk/whats_on/London/">London</a></li><li><a href="https://www.allgigs.co.uk/whats_on/Birmingham/">Birmingham</a></li><li><a href="https://www.allgigs.co.uk/whats_on/Bristol/">Bristol</a></li><li><a href="https://www.allgigs.co.uk/whats_on/Edinburgh/">Edinburgh</a></li><li><a href="https://www.allgigs.co.uk/whats_on/Glasgow/">Glasgow</a></li><li><a href="https://www.allgigs.co.uk/whats_on/Liverpool/">Liverpool</a></li><li><a href="https://www.allgigs.co.uk/whats_on/Manchester/">Manchester</a></li><li><a href="https://www.allgigs.co.uk/whats_on/Newcastle-upon-Tyne/">Newcastle-upon-Tyne</a></li><li><a href="https://www.allgigs.co.uk/whats_on/">More</a></li></ul></li><li>By Genre:<ul><li><a href="https://www.allgigs.co.uk/whats_on/guide/pop.html">Pop</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/urban.html">Urban</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/rock_and_alternative.html">Rock/ Alternative</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/metal.html">Metal</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/punk.html">Punk</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/jazz_and_blues.html">Jazz/ Blues</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/folk_and_world.html">Folk/ Roots</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/reggae.html">Reggae</a></li><li><a href="https://www.allgigs.co.uk/whats_on/guide/classical.html">Classical</a></li></ul></li><li>By Price:<ul><li><a href="https://www.allgigs.co.uk/search/gigs/free/">Free!</a></li><li><a href="https://www.allgigs.co.uk/search/gigs/under_a_fiver/">Under &pound;5</a></li><li><a href="https://www.allgigs.co.uk/search/gigs/under_a_tenner/">Under &pound;10</a></li></ul></li><li>Guides:<ul><li><a href="https://www.allgigs.co.uk/WeeklyEventGuide/">The Week Ahead</a></li><li><a href="https://www.allgigs.co.uk/OnsaleGuide/">On-Sale</a></li><li><a href="https://www.allgigs.co.uk/FestivalGuide/">Festivals</a></li><li><a href="https://www.allgigs.co.uk/HipHopGuide">Hip Hop</a></li><li><a href="https://www.allgigs.co.uk/click/charityroundup/">Charity Events</a></li></ul></li><li>Contact Us:<ul><li><a href="https://www.allgigs.co.uk/Contact.php">Contact Us</a></li><li><a href="https://www.allgigs.co.uk/Advertise.php">Advertise</a></li><li><a href="https://www.allgigs.co.uk/AddMyDetails.php">Add Your Event</a></li></ul></li><li>More:<ul><li><a href="javascript:focusAndSelectInput('searchbox')">Search</a></li><li><a href="https://www.allgigs.co.uk/newsletter.php">Newsletter</a></li><li><a href="https://www.allgigs.co.uk/News.php">News</a></li><li><a href="https://www.allgigs.co.uk/specialoffers/">Special Offers</a></li><li><a href="https://www.allgigs.co.uk/Competitions.php">Competitions</a></li><li><a href="https://www.allgigs.co.uk/aboutus.php">About Us</a></li><li><a href="https://www.allgigs.co.uk/cookies/">Cookie Policy</a></li><li><a href="https://www.allgigs.co.uk/Help.php">Help</a></li></ul></li><li class="social">Follow Us:<ul class="feeds"><li class="facebook"><a rel="nofollow" href="https://www.facebook.com/allgigs" target="_blank" title="Follow allgigs on Facebook">Facebook</a></li><li class="twitter"><a rel="nofollow" href="https://twitter.com/allgigs" target="_blank" title="Follow allgigs on Twitter">Twitter</a></li><li class="pinterest"><a rel="nofollow" href="https://pinterest.com/allgigs" target="_blank" title="Follow allGigs on Pinterest">Pinterest</a></li><li class="RSS"><a href="https://www.allgigs.co.uk/feeds/rss/news.rss" target="_blank" title="allgigs news feed">News</a></li><div class="clear"></div></ul></li></ul></div>
<div class="clear"></div></div><!--/page--><div id="legalinfo">
<p>&copy; 2001 - 2017 AllGigs  Limited, company number: 05113554. Registered office: 3 Silverdale Drive, London, SE9 4DH, England<br/>
All Rights Reserved. Use of this site is subject to our <a href="https://www.allgigs.co.uk/terms.php" >Terms and Conditions</a>.</p>
</div>
<script type="text/javascript">
/* <![CDATA[ */
var google_conversion_id = 983433814;
var google_conversion_label = "tQQ1CLL8gAcQ1oT41AM";
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */
</script>
<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
</script>
<noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/983433814/?value=0&amp;label=tQQ1CLL8gAcQ1oT41AM&amp;guid=ON&amp;script=0"/>
</div>
</noscript>
</body>
</html>
